уменьшить размер Базы данных

Post Reply
sawebbo
Posts: 10
Joined: Wed Mar 16, 2016 2:00 pm

уменьшить размер Базы данных

Post by sawebbo »

У меня на одном сидже гигантский размер БД, виноват крон, файлы cron.log и rot.log (гигантских размеров) Как правильно поступить?
1. Поправить крон
2. можно удалить cron.log и rot.log в папке /public_html/scj/logs ?
если можно удалить? то как сформировать новые файлы cron.log и rot.log (допустим скопировать с другого сиджа, отредактировать файлы через панель сервера не дает) или скрипт их сам создаст?
3 Может сделать ресет сиджа, для формирования новых cron.log и rot.log.
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: уменьшить размер Базы данных

Post by admin »

Если они автоматом не обрезаются значит крон запускается не каждую минуту.
Можете конечно обнулить файлы (echo > cron.log) но они все равно вырастут через какое-то время.
Вывод - я бы смотрел почему крон не каждую минуту.
Don't forget to run script update
sawebbo
Posts: 10
Joined: Wed Mar 16, 2016 2:00 pm

Re: уменьшить размер Базы данных

Post by sawebbo »

Кроны сейчас заработали, в cron.log и rot.log была ошибка фатал еррор. НО БД как была огромная по размерам так и осталась
Все место в указаных БД занимают таблицы rot_page_items:
1.1G /var/lib/mysql/admin_29/rot_page_items.MYD
1.7G /var/lib/mysql/admin_16/rot_page_items.MYD
172M /var/lib/mysql/admin_sgscj/rot_page_items.MYD
1003M /var/lib/mysql/admin_11/rot_page_items.MYD

Можно ли их очистить и как это сделать безопасно?
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: уменьшить размер Базы данных

Post by admin »

Какая именно ошибка ?

Через минуту после запуска крона ничего не будет, оно раз в сутки очищает лишние данные.
Don't forget to run script update
sawebbo
Posts: 10
Joined: Wed Mar 16, 2016 2:00 pm

Re: уменьшить размер Базы данных

Post by sawebbo »

Вот такая ошибка была
<br />
<b>Fatal error</b>: Allowed memory size of 134217728 bytes exhausted
(tried to allocate 1471823870 bytes) in
<b>/home/admin/domains/domen.com/public_html/scj/admin/files/logs.php</b>
on line <b>0</b><br />
err
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: уменьшить размер Базы данных

Post by admin »

Это не в cron.log точно
это из админки когда вы пытались просмотреть логи которые были огромного размера.
Don't forget to run script update
sawebbo
Posts: 10
Joined: Wed Mar 16, 2016 2:00 pm

Re: уменьшить размер Базы данных

Post by sawebbo »

Да эту ощибку убрал саппорт сервера, вот их ответ
>> Проблема может быть комплексной, поэтому мы пока ограничилисть
>> следующими мерами:
>> - обновлена панель и очищена очередь сообщений о брутфорсе.
>> - отключено логирование брутфорс
>> - произведен тюниг nginx для кеша открытых файлов
>> - увеличены параметры mysql: thread_cache_size=4->16,
>> table_cache=1024->2048
>> - очищены логи cron.log и rot.log для всех доменов.

Просят спросить у вас, как разработчика скрипта, как безопасно избавиться от огромного размера файлов БД
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: уменьшить размер Базы данных

Post by admin »

Убедиться что cron.php запускается каждую миниуту и он сам очистит базу и урежет логи.
Don't forget to run script update
sawebbo
Posts: 10
Joined: Wed Mar 16, 2016 2:00 pm

Re: уменьшить размер Базы данных

Post by sawebbo »

Да размер БД уменьшился, при апдейте скрипта до 1.51, крон таки обрезал лишние кг ;)
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: уменьшить размер Базы данных

Post by admin »

Тут попрос не в апдейте все же а именно запуске крона, тк разные задания стоят на разные минуты часа и если в эту минутут не запускается то задание не выполняется.
Don't forget to run script update
Post Reply