У меня на одном сидже гигантский размер БД, виноват крон, файлы cron.log и rot.log (гигантских размеров) Как правильно поступить?
1. Поправить крон
2. можно удалить cron.log и rot.log в папке /public_html/scj/logs ?
если можно удалить? то как сформировать новые файлы cron.log и rot.log (допустим скопировать с другого сиджа, отредактировать файлы через панель сервера не дает) или скрипт их сам создаст?
3 Может сделать ресет сиджа, для формирования новых cron.log и rot.log.
уменьшить размер Базы данных
Re: уменьшить размер Базы данных
Если они автоматом не обрезаются значит крон запускается не каждую минуту.
Можете конечно обнулить файлы (echo > cron.log) но они все равно вырастут через какое-то время.
Вывод - я бы смотрел почему крон не каждую минуту.
Можете конечно обнулить файлы (echo > cron.log) но они все равно вырастут через какое-то время.
Вывод - я бы смотрел почему крон не каждую минуту.
Don't forget to run script update
Re: уменьшить размер Базы данных
Кроны сейчас заработали, в cron.log и rot.log была ошибка фатал еррор. НО БД как была огромная по размерам так и осталась
Все место в указаных БД занимают таблицы rot_page_items:
1.1G /var/lib/mysql/admin_29/rot_page_items.MYD
1.7G /var/lib/mysql/admin_16/rot_page_items.MYD
172M /var/lib/mysql/admin_sgscj/rot_page_items.MYD
1003M /var/lib/mysql/admin_11/rot_page_items.MYD
Можно ли их очистить и как это сделать безопасно?
Все место в указаных БД занимают таблицы rot_page_items:
1.1G /var/lib/mysql/admin_29/rot_page_items.MYD
1.7G /var/lib/mysql/admin_16/rot_page_items.MYD
172M /var/lib/mysql/admin_sgscj/rot_page_items.MYD
1003M /var/lib/mysql/admin_11/rot_page_items.MYD
Можно ли их очистить и как это сделать безопасно?
Re: уменьшить размер Базы данных
Какая именно ошибка ?
Через минуту после запуска крона ничего не будет, оно раз в сутки очищает лишние данные.
Через минуту после запуска крона ничего не будет, оно раз в сутки очищает лишние данные.
Don't forget to run script update
Re: уменьшить размер Базы данных
Вот такая ошибка была
<br />
<b>Fatal error</b>: Allowed memory size of 134217728 bytes exhausted
(tried to allocate 1471823870 bytes) in
<b>/home/admin/domains/domen.com/public_html/scj/admin/files/logs.php</b>
on line <b>0</b><br />
err
<br />
<b>Fatal error</b>: Allowed memory size of 134217728 bytes exhausted
(tried to allocate 1471823870 bytes) in
<b>/home/admin/domains/domen.com/public_html/scj/admin/files/logs.php</b>
on line <b>0</b><br />
err
Re: уменьшить размер Базы данных
Это не в cron.log точно
это из админки когда вы пытались просмотреть логи которые были огромного размера.
это из админки когда вы пытались просмотреть логи которые были огромного размера.
Don't forget to run script update
Re: уменьшить размер Базы данных
Да эту ощибку убрал саппорт сервера, вот их ответ
>> Проблема может быть комплексной, поэтому мы пока ограничилисть
>> следующими мерами:
>> - обновлена панель и очищена очередь сообщений о брутфорсе.
>> - отключено логирование брутфорс
>> - произведен тюниг nginx для кеша открытых файлов
>> - увеличены параметры mysql: thread_cache_size=4->16,
>> table_cache=1024->2048
>> - очищены логи cron.log и rot.log для всех доменов.
Просят спросить у вас, как разработчика скрипта, как безопасно избавиться от огромного размера файлов БД
>> Проблема может быть комплексной, поэтому мы пока ограничилисть
>> следующими мерами:
>> - обновлена панель и очищена очередь сообщений о брутфорсе.
>> - отключено логирование брутфорс
>> - произведен тюниг nginx для кеша открытых файлов
>> - увеличены параметры mysql: thread_cache_size=4->16,
>> table_cache=1024->2048
>> - очищены логи cron.log и rot.log для всех доменов.
Просят спросить у вас, как разработчика скрипта, как безопасно избавиться от огромного размера файлов БД
Re: уменьшить размер Базы данных
Убедиться что cron.php запускается каждую миниуту и он сам очистит базу и урежет логи.
Don't forget to run script update
Re: уменьшить размер Базы данных
Да размер БД уменьшился, при апдейте скрипта до 1.51, крон таки обрезал лишние кг 
Re: уменьшить размер Базы данных
Тут попрос не в апдейте все же а именно запуске крона, тк разные задания стоят на разные минуты часа и если в эту минутут не запускается то задание не выполняется.
Don't forget to run script update







