It's a fresh install the thing is that if i try to delete those files the script will stop working because they are located inside scj folder so i assumed is part of the script but at the same time the script says they shouldn't be there. Even after the update they are still there.admin wrote: Mon May 27, 2024 7:51 am 1. import into Active status - that's correct
2. did you copy files from another server or installed a new one over existing?
anyway try to run update please
if it doesn't help - please send me access to the server, i'll check it out
installation error
-
poweromania
- Posts: 12
- Joined: Thu Apr 20, 2017 5:59 am
Re: installation error
-
poweromania
- Posts: 12
- Joined: Thu Apr 20, 2017 5:59 am
Re: installation error
I read that and it shows my real ip for the REMOTE_ADDRadmin wrote: Mon May 27, 2024 8:52 am proxy
https://smartcj.com/wiki/doku.php?id=ng ... ip_address
Extra URL warning - do you need any explanation here?
Re: installation error
poweromania wrote: Mon May 27, 2024 9:45 amIt's a fresh install the thing is that if i try to delete those files the script will stop working because they are located inside scj folder so i assumed is part of the script but at the same time the script says they shouldn't be there. Even after the update they are still there.admin wrote: Mon May 27, 2024 7:51 am 1. import into Active status - that's correct
2. did you copy files from another server or installed a new one over existing?
anyway try to run update please
if it doesn't help - please send me access to the server, i'll check it out
ok, let fix it step by step
if update doesn't fix this warning - send ssh access plz
Don't forget to run script update
Re: installation error
Thank you, i've missed files list for php 8.2
fixed and looks ok now
Proxy warning
I see variable
$_SERVER['HTTP_X_FORWARDED_FOR']
while I'm not behind proxy
fixed and looks ok now
Proxy warning
I see variable
$_SERVER['HTTP_X_FORWARDED_FOR']
while I'm not behind proxy
Don't forget to run script update
-
poweromania
- Posts: 12
- Joined: Thu Apr 20, 2017 5:59 am
Re: installation error
Is there any guide i can follow in order to activate REAL_IP only and disable HTTP_X_FORWARDED_FOR since i can't find anything useful online.
Re: installation error
To set up the REAL_IP and remove the HTTP_X_FORWARDED_FOR header in Nginx, you need to configure the real_ip module. This module is designed to replace the client's IP address with the address of the load balancer or proxy server that forwarded the request. Here's how you can do it:
Locate and open your Nginx configuration file (usually /etc/nginx/nginx.conf or /etc/nginx/conf.d/default.conf).
Inside the http block, add the following lines to define the trusted IP addresses (replace 192.168.1.0/24 with the appropriate IP or subnet) like
set_real_ip_from 192.168.1.0/24;
Also do you have something like
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
in nginx conf?
Locate and open your Nginx configuration file (usually /etc/nginx/nginx.conf or /etc/nginx/conf.d/default.conf).
Inside the http block, add the following lines to define the trusted IP addresses (replace 192.168.1.0/24 with the appropriate IP or subnet) like
set_real_ip_from 192.168.1.0/24;
Also do you have something like
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
in nginx conf?
Don't forget to run script update
-
poweromania
- Posts: 12
- Joined: Thu Apr 20, 2017 5:59 am
Re: installation error
sorry to ask but should i replaceadmin wrote: Tue May 28, 2024 4:59 pm To set up the REAL_IP and remove the HTTP_X_FORWARDED_FOR header in Nginx, you need to configure the real_ip module. This module is designed to replace the client's IP address with the address of the load balancer or proxy server that forwarded the request. Here's how you can do it:
Locate and open your Nginx configuration file (usually /etc/nginx/nginx.conf or /etc/nginx/conf.d/default.conf).
Inside the http block, add the following lines to define the trusted IP addresses (replace 192.168.1.0/24 with the appropriate IP or subnet) like
set_real_ip_from 192.168.1.0/24;
Also do you have something like
proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
in nginx conf?
Code: Select all
(replace 192.168.1.0/24 with the appropriate IP or subnet)-
poweromania
- Posts: 12
- Joined: Thu Apr 20, 2017 5:59 am
Re: installation error
no i don't have anything like proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; inside config file
Re: installation error
right, you need to add this linepoweromania wrote: Wed May 29, 2024 6:31 am no i don't have anything like proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; inside config file
Don't forget to run script update







