installation error

poweromania
Posts: 12
Joined: Thu Apr 20, 2017 5:59 am

Re: installation error

Post by poweromania »

admin wrote: Mon May 27, 2024 7:51 am 1. import into Active status - that's correct

2. did you copy files from another server or installed a new one over existing?
anyway try to run update please
if it doesn't help - please send me access to the server, i'll check it out
It's a fresh install the thing is that if i try to delete those files the script will stop working because they are located inside scj folder so i assumed is part of the script but at the same time the script says they shouldn't be there. Even after the update they are still there.
poweromania
Posts: 12
Joined: Thu Apr 20, 2017 5:59 am

Re: installation error

Post by poweromania »

admin wrote: Mon May 27, 2024 8:52 am proxy

https://smartcj.com/wiki/doku.php?id=ng ... ip_address


Extra URL warning - do you need any explanation here?
I read that and it shows my real ip for the REMOTE_ADDR
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: installation error

Post by admin »

poweromania wrote: Mon May 27, 2024 9:45 am
admin wrote: Mon May 27, 2024 7:51 am 1. import into Active status - that's correct

2. did you copy files from another server or installed a new one over existing?
anyway try to run update please
if it doesn't help - please send me access to the server, i'll check it out
It's a fresh install the thing is that if i try to delete those files the script will stop working because they are located inside scj folder so i assumed is part of the script but at the same time the script says they shouldn't be there. Even after the update they are still there.

ok, let fix it step by step

if update doesn't fix this warning - send ssh access plz
Don't forget to run script update
poweromania
Posts: 12
Joined: Thu Apr 20, 2017 5:59 am

Re: installation error

Post by poweromania »

I send a PM
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: installation error

Post by admin »

Thank you, i've missed files list for php 8.2
fixed and looks ok now


Proxy warning

I see variable

$_SERVER['HTTP_X_FORWARDED_FOR']

while I'm not behind proxy
Don't forget to run script update
poweromania
Posts: 12
Joined: Thu Apr 20, 2017 5:59 am

Re: installation error

Post by poweromania »

Is there any guide i can follow in order to activate REAL_IP only and disable HTTP_X_FORWARDED_FOR since i can't find anything useful online.
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: installation error

Post by admin »

To set up the REAL_IP and remove the HTTP_X_FORWARDED_FOR header in Nginx, you need to configure the real_ip module. This module is designed to replace the client's IP address with the address of the load balancer or proxy server that forwarded the request. Here's how you can do it:

Locate and open your Nginx configuration file (usually /etc/nginx/nginx.conf or /etc/nginx/conf.d/default.conf).
Inside the http block, add the following lines to define the trusted IP addresses (replace 192.168.1.0/24 with the appropriate IP or subnet) like

set_real_ip_from 192.168.1.0/24;




Also do you have something like


proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

in nginx conf?
Don't forget to run script update
poweromania
Posts: 12
Joined: Thu Apr 20, 2017 5:59 am

Re: installation error

Post by poweromania »

admin wrote: Tue May 28, 2024 4:59 pm To set up the REAL_IP and remove the HTTP_X_FORWARDED_FOR header in Nginx, you need to configure the real_ip module. This module is designed to replace the client's IP address with the address of the load balancer or proxy server that forwarded the request. Here's how you can do it:

Locate and open your Nginx configuration file (usually /etc/nginx/nginx.conf or /etc/nginx/conf.d/default.conf).
Inside the http block, add the following lines to define the trusted IP addresses (replace 192.168.1.0/24 with the appropriate IP or subnet) like

set_real_ip_from 192.168.1.0/24;




Also do you have something like


proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;

in nginx conf?
sorry to ask but should i replace

Code: Select all

(replace 192.168.1.0/24 with the appropriate IP or subnet)
with my server ip or subnet?
poweromania
Posts: 12
Joined: Thu Apr 20, 2017 5:59 am

Re: installation error

Post by poweromania »

no i don't have anything like proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; inside config file
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: installation error

Post by admin »

poweromania wrote: Wed May 29, 2024 6:31 am no i don't have anything like proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; inside config file
right, you need to add this line
Don't forget to run script update
Post Reply