Во время апдейта вновь установленных TCMS всплыл один нюанс:
Mysql error:: 1064 (You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IGNORE TABLE rot_pages ADD UNIQUE (name)' at line 1) (db_link) in query ALTER IGNORE TABLE rot_pages ADD UNIQUE (name) .....
Также при попытке конвертировать некоторые таблицы в InnoDB вылезли ошибки:
Processing table pornliebe_tcms.rot_cell_data
ERROR 1067 (42000) at line 1: Invalid default value for 'date'
Processing table pornliebe_tcms.rot_comments
ERROR 1067 (42000) at line 1: Invalid default value for 'date'
Processing table pornliebe_tcms.rot_galleries
ERROR 1067 (42000) at line 1: Invalid default value for 'activation_date'
Processing table pornliebe_tcms.rot_page_items
ERROR 1067 (42000) at line 1: Invalid default value for 'date'
Processing table pornliebe_tcms.rot_users
ERROR 1067 (42000) at line 1: Invalid default value for 'reg_date'
У админов есть подозрение что причина возникновении данной ошибки - в несовместимости TCMS и СУБД Percona (на этом сервере установлена Percona, на остальных хостах у нас стандартом является MariaDB). Админы просят узнать мнение разработчиков по этому вопросу.
TCMS и СУБД Percona
Re: TCMS и СУБД Percona
Какая версия перконы? поставлю у себя пока для теста
Don't forget to run script update
Re: TCMS и СУБД Percona
поставил 5.7 себе - все ок
видимо какие то хитрые настройки
например смотрю
Processing table pornliebe_tcms.rot_cell_data
ERROR 1067 (42000) at line 1: Invalid default value for 'date'
в scj2.sql
`date` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
админ мог бы уточнить что именно как именно надо делать что б повторить ошибку ?
видимо какие то хитрые настройки
например смотрю
Processing table pornliebe_tcms.rot_cell_data
ERROR 1067 (42000) at line 1: Invalid default value for 'date'
в scj2.sql
`date` datetime NOT NULL DEFAULT '0000-00-00 00:00:00',
админ мог бы уточнить что именно как именно надо делать что б повторить ошибку ?
Don't forget to run script update
Re: TCMS и СУБД Percona
админ пишет
обнаружилась такая настройка, да. Главная причина в том, что сервер был подготовлен под определенные задачи, а потом там появились tcms.
Вторую ошибку с датами скорее всего удасться решить. Но он ничего не ответил по поводу первой "Mysql error:: 1064 (You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IGNORE TABLE rot_pages ADD UNIQUE (name)' at line 1) (db_link) in query ALTER IGNORE TABLE rot_pages ADD UNIQUE (name) . ...."
Не мог бы он подтвердить, что его скрипты полностью совместимы с Percona 5.7? 5.7 ветка это современные реалии. Если так, то будем пробовать решать с текущим положением вещей
Re: TCMS и СУБД Percona
Просто запустите ап еще раз - будет все ок.
Don't forget to run script update
Re: TCMS и СУБД Percona
всё ок сейчас, спасибо







