Hello,
When my admin tries to load the Sphinx config it fails:
root@elsocorro:/root # su serverco
$ indexer --all --rotate
Sphinx 2.1.7-release (rel21-r4638)
Copyright (c) 2001-2014, Andrew Aksyonoff
Copyright (c) 2008-2014, Sphinx Technologies Inc (http://sphinxsearch.com)
using config file '/usr/local/etc/sphinx.conf'...
indexing index 'scj_index'...
ERROR: index 'scj_index': sql_query: Unknown column 'tags' in 'field list' (DSN=mysql://serverco_scj:***@localhost:3306/serverco_scj09).
total 0 docs, 0 bytes
total 0.002 sec, 0 bytes/sec, 0.00 docs/sec
total 0 reads, 0.000 sec, 0.0 kb/call avg, 0.0 msec/call avg
total 0 writes, 0.000 sec, 0.0 kb/call avg, 0.0 msec/call avg
$
The query is
SELECT id, date, tags, alt, description, duration, sponsor_id, rgroup FROM
rot_galleries as g JOIN rot_gallery_stats AS gs ON g.id = gs.thumb_id WHERE status = 1 and gs.best_thumb = 'yes' and rgroup !
= 0
He thinks maybe my scj install is out of date?
sphinx error
Re: sphinx error
There's a chance that you use wrong sphinx query string
Check out http://smartcj.com/wiki/doku.php?id=new_rotation_sphinx
there are strings for 49, 50 and 51.
Make sure that you use an appropriate one.
Check out http://smartcj.com/wiki/doku.php?id=new_rotation_sphinx
there are strings for 49, 50 and 51.
Make sure that you use an appropriate one.
Don't forget to run script update
Re: sphinx error
Thanks, that problem seems to be solved.
I entered:
Sphinx Host: localhost
Sphinx Port: 9312
Sphinx Search Index: /usr/home/serverco/domains/mydomain.com/public_html/scj/sphinx/scj_index
Are these correct?
I entered:
Sphinx Host: localhost
Sphinx Port: 9312
Sphinx Search Index: /usr/home/serverco/domains/mydomain.com/public_html/scj/sphinx/scj_index
Are these correct?
Re: sphinx error
I get empty search results;
SmartCJ shows following error messages:
"Quick scj folder check returns following warnings:
sphinx is not a part of SCJ. Check it mannualy
sphinx.tar is not a part of SCJ. Check it mannualy"
Any suggestion on what I shoud check/do now?
Thanks.
SmartCJ shows following error messages:
"Quick scj folder check returns following warnings:
sphinx is not a part of SCJ. Check it mannualy
sphinx.tar is not a part of SCJ. Check it mannualy"
Any suggestion on what I shoud check/do now?
Thanks.
Re: sphinx error
Do you get results in ssh ?
like
search -i your_index keywords
like
search -i your_index keywords
Don't forget to run script update







