403 Forbidden in the last version (1.5)

blogwebmaster
Posts: 26
Joined: Mon Oct 07, 2013 6:31 pm

403 Forbidden in the last version (1.5)

Post by blogwebmaster »

After some trouble with import, which were discussed here - http://smartcj.com/viewtopic.php?f=2&t=89439 , I decided to start over at a new domain and get things exactly as I was told in the topic.

1. Updated SCJ
2. Updated IM

In the new version I got problems with 403 Forbidden. Here's what I got in the Main tab:
http://clip2net.com/s/5UTbyi

As I understand, the second error isn't critical, but the first one leads to 403 Forbidden error when trying to access the site.

After reading Wiki about the issue, I've asked the hosting support to remove HTTP_X_FORWARDED_FOR, which was noticed in phpinfo. But that caused another type of error: http://clip2net.com/s/5UT2Io and the domain began to show a list of folders, insted of the mainpage. So I asked the hosting support to turn everything with HTTP_X_FORWARDED_FOR back again and now asking for help here.

Thanks forward.
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: 403 Forbidden in the last version (1.5)

Post by admin »

Well, you can get more skilled admin I guess who can setup server without fields that are usually being added by proxy server..
Don't forget to run script update
blogwebmaster
Posts: 26
Joined: Mon Oct 07, 2013 6:31 pm

Re: 403 Forbidden in the last version (1.5)

Post by blogwebmaster »

=)
Can you post a more concrete instruction, what to do? So that my hosting admins (unfortunately, I can't change them) can handle the issue. Cause they made exactly what was in the wiki, and that didn't help.

Is it normal, that I didn't get those problems with 1.49, but they appear at 1.5?
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: 403 Forbidden in the last version (1.5)

Post by admin »

49 just doesn't have that check build in.
Don't forget to run script update
blogwebmaster
Posts: 26
Joined: Mon Oct 07, 2013 6:31 pm

Re: 403 Forbidden in the last version (1.5)

Post by blogwebmaster »

Okay. What about some instructions? =) Sorry, but I really don't know what to do =)
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: 403 Forbidden in the last version (1.5)

Post by admin »

Honestly It would be better to talk to admin.
Don't forget to run script update
blogwebmaster
Posts: 26
Joined: Mon Oct 07, 2013 6:31 pm

Re: 403 Forbidden in the last version (1.5)

Post by blogwebmaster »

OK, but I already did it, and they've just removed the HTTP_X_FORWARDED_FOR and that didn't help =(
I'll try again. Thank you.

About 49 - the site was working on that version. On 50 I've got 403.
blogwebmaster
Posts: 26
Joined: Mon Oct 07, 2013 6:31 pm

Re: 403 Forbidden in the last version (1.5)

Post by blogwebmaster »

Maybe there's another cause of 403 error?
admin
Site Admin
Posts: 37994
Joined: Wed Sep 10, 2008 11:43 am

Re: 403 Forbidden in the last version (1.5)

Post by admin »

No need to guess - check server logs.
Don't forget to run script update
blogwebmaster
Posts: 26
Joined: Mon Oct 07, 2013 6:31 pm

Re: 403 Forbidden in the last version (1.5)

Post by blogwebmaster »

Well, as I found out the problem is that I've got no index.php in site folder after update =) How could that be, and what can be done now? =)
Post Reply