I have to move my sites to a new server, but I encountered a problem. I moved them using whm feature "copy an account from another server", everything went smoothly. The home pages of the sites open fine with thumbs and everything, admin panel opens fine too, but the categories and galleries pages show the error: Warning: mysql_connect(): Access denied for user 'nobody'@'localhost' (using password: NO) in /home/tx3543/public_html/scj/includes/db_modules/mysql.php on line 11
Can not connect to database server.
I tried installing a fresh smartcj from 0, and got the same error: http://bit.ly/1dd31Gm
This error appears on all the sites galleries and categories pages. I though that could happen because i wasn't opening it with a domain, but tried parking one and got the same error. The server ip is on the allowed host on mysql settings, and everything seems the same as the previous server where everything works. The error appears both opening the urls with nginx or with apache (adding :8081 to the url). I also tried enabling debug messages in out.php from the admin panel but no extra errors are shown.
Any advice?
Access denied for user 'nobody'@'localhost'
Re: Access denied for user 'nobody'@'localhost'
Did you try to run update ?
Don't forget to run script update
Re: Access denied for user 'nobody'@'localhost'
The problem was the new server had a different php version than the previous one. Installed the same php version and now it works.
I have another problem I will ask here instead of creating a new thread.
One of the sites is not counting stats on the "History : Last 7 days" section, the "Main Stats" does show hits increasing but the History stays at 0, what could be happening?
I have another problem I will ask here instead of creating a new thread.
One of the sites is not counting stats on the "History : Last 7 days" section, the "Main Stats" does show hits increasing but the History stays at 0, what could be happening?
Re: Access denied for user 'nobody'@'localhost'
You don't run cron.php every minute.
Don't forget to run script update
Re: Access denied for user 'nobody'@'localhost'
Crons are running fine, but I tried running it manually and saw the error: "Mysql error: 1146 (Table 'user_user.rot_gallery_stats29' doesn't exist)"admin wrote:You don't run cron.php every minute.
I am using an external db, I tried unlinking and relinking the db but the table still doesn't exists so I created it manually using the structure from one of the other rot_gallery_statsXX tables. Now the error doesn't show up when running rot.php, but History stats remain at 0 while the Main Stats keep increasing.
Re: Access denied for user 'nobody'@'localhost'
And you are sure that there are records in cron.log each hour at 00 minutes ?
like 3:00
4:00 and so on ?
like 3:00
4:00 and so on ?
Don't forget to run script update
Re: Access denied for user 'nobody'@'localhost'
These are the last cron.log lines:admin wrote:And you are sure that there are records in cron.log each hour at 00 minutes ?
like 3:00
4:00 and so on ?
Code: Select all
2013-08-25 16:52 Process data (0.0346710681915, 0.0346710681915)
2013-08-25 16:52 Process traders (0.163623094559, 0.128952026367)
2013-08-25 16:53 Process data (1.13657212257, 1.13657212257)
2013-08-25 16:53 Process traders (1.58073401451, 0.444161891937)
2013-08-25 16:54 Process data (0.0373589992523, 0.0373589992523)
2013-08-25 16:54 Process traders (0.0957968235016, 0.0584378242493)
2013-08-25 16:54 Ext Stats culotetas.com (2.79835796356, 2.70256114006)
2013-08-25 16:55 Process data (0.208101987839, 0.208101987839)
2013-08-25 16:55 Process traders (0.621210098267, 0.413108110428)
2013-08-25 16:55 Old copy skill running from 16:54:05 (2.5077381134, 1.88652801514)
2013-08-25 16:56 Process data (0.907109975815, 0.907109975815)
2013-08-25 16:56 Process traders (1.64747810364, 0.740368127823)
2013-08-25 16:57 Process data (0.040470123291, 0.040470123291)
2013-08-25 16:57 Process traders (0.691643953323, 0.651173830032)
2013-08-25 16:58 Process data (0.370796203613, 0.370796203613)
2013-08-25 16:58 Process traders (0.79591012001, 0.425113916397)
2013-08-25 16:58 Processing toplist top.html (3.28437900543, 2.48846888542)
2013-08-25 16:58 Processing toplist f_top.html (3.44140005112, 0.157021045685)
2013-08-25 16:59 Process data (0.194884061813, 0.194884061813)
2013-08-25 16:59 Process traders (0.476388931274, 0.281504869461)
2013-08-25 16:59 Old copy skill running from 16:58:05 (2.02347397804, 1.54708504677)
2013-08-25 17:00 Reset 17 .. 16 (0.03284907341, 0.03284907341)
2013-08-25 17:00 Process data (0.047847032547, 0.014997959137)
2013-08-25 17:00 Process traders (0.125648975372, 0.0778019428253)
2013-08-25 17:00 Checking hourly forces (0.461420059204, 0.335771083832)
2013-08-25 17:01 Process data (0.133281946182, 0.133281946182)
2013-08-25 17:01 Process traders (1.01968288422, 0.886400938034) Re: Access denied for user 'nobody'@'localhost'
I don't know.
PM admin and ssh access - i'll check it.
PM admin and ssh access - i'll check it.
Don't forget to run script update







