User Tools

Site Tools


Writing /home/user/smartcj.com/wiki/data/cache/1/17ccdda5d10f2c9e1684648967832232.i failed
Unable to save cache file. Hint: disk full; file permissions; safe_mode setting.
Writing /home/user/smartcj.com/wiki/data/cache/1/17ccdda5d10f2c9e1684648967832232.metadata failed
ru:subscription

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
ru:subscription [2020/09/09 09:18] – [Subscription turns into free version] adminru:subscription [2026/06/01 07:52] (current) – [Subscription turns into free version] admin
Line 16: Line 16:
 3. В  http://smartcj.com/forum/portal.php?action=domains напротив каждого домена 2 ссылки - купить лицензию или подписку. 3. В  http://smartcj.com/forum/portal.php?action=domains напротив каждого домена 2 ссылки - купить лицензию или подписку.
  
-По клику на подписку - с аккаунта снимается 4.99 в месяц.+По клику на подписку - с аккаунта снимается 5.99 в месяц.
  
 Когда вы нажимаете на кнопочку подписки - с аккаунта снимается сумма подписки и создается задание на генерацию новой лицензии. Когда вы нажимаете на кнопочку подписки - с аккаунта снимается сумма подписки и создается задание на генерацию новой лицензии.
  
-После генерации лицензии она сразу высылается вам на емыл и ее можно скачать в http://smartcj.com/forum/portal.php?action=domains. Когда вы зальете лицензию в каталог scj, то на Home пропадет надпись Free version, скрипт перестанет брать 1%.+После генерации лицензии она сразу высылается вам на емайл и так же ее можно скачать в http://smartcj.com/forum/portal.php?action=domains. Когда вы зальете лицензию в каталог scj, то на Home пропадет надпись Free version, скрипт перестанет брать 1%.
  
 Однако, что бы было проще, скрипт раз в сутки проверяет нет ли для него новой лицензии и, если есть, то скачивает себе. Те при подписке можно вообще ничего руками не делать, скрипт сделает все сам, но это будет не мгновенно. Однако, что бы было проще, скрипт раз в сутки проверяет нет ли для него новой лицензии и, если есть, то скачивает себе. Те при подписке можно вообще ничего руками не делать, скрипт сделает все сам, но это будет не мгновенно.
Line 41: Line 41:
  
 **Paid**  - платная версия версия, цены http://smartcj.com/buysmartcj.shtml. Ничего не отбирает, бесплатные апдейты в пределах одной ветки **Paid**  - платная версия версия, цены http://smartcj.com/buysmartcj.shtml. Ничего не отбирает, бесплатные апдейты в пределах одной ветки
- 
  
 **Перенос лицензий** - лицензия переносится только если домен проэкспарился и его можно зарегистрировать.  **Перенос лицензий** - лицензия переносится только если домен проэкспарился и его можно зарегистрировать. 
Line 48: Line 47:
  
 **Куда заливать ключ** - ключ храниться в папке scj , если вы заливаете его руками то именно туда и надо класть его. **Куда заливать ключ** - ключ храниться в папке scj , если вы заливаете его руками то именно туда и надо класть его.
 + Для версии 1 это scj_pro.lic, для версии 2 - scj2.lic
 ====== FAQ ====== ====== FAQ ======
  
Line 71: Line 70:
 99% случаев - криво настроен хостинг. 99% случаев - криво настроен хостинг.
  
-Лицензиями занимается IonCube (мод для пхп), те скрипт запускается как: сначала запускается ioncube, проверяет лицензию, если все ок - запускает сам скрипт.+Лицензиями занимается IonCube (мод для пхп), те скрипт запускается так: сначала запускается ioncube, проверяет лицензию, если все ок - запускает сам скрипт. Те лицензиями управляет НЕ SmartCJ. 
 + 
 +Если по какой-то причине лицензия не прошла и скрипт не будет запущен, IonCube  запускает файл scj/ioncube_fallback.php , исходник лежит у вас на хосте, не надо быть програмистом что разобраться что там происходит. А конкретно он меняет лицензию на фришную что б смарт смог работать. 
 + 
 +99% проблем - это запуск скрипта с HTTP_HOST отличным от того для которого выпущена лицензия, о чем скрипт и пишет в scj/logs/error.log  Возникает эта проблема из-за криво настроенного хостинга, что можно видеть по записи в error.log когда на хосте с domain.com в error.log записи с http_host = domain2.com  (либо вообще нет HTTP_HOST, либо например  [HTTP_HOST] => localhost)
  
-Если по какой-то причине лицензия не прошла и скрипт не был запущен, IonCube  запускает файл scj/ioncube_fallback.php , исходник лежит у вас на хосте, не надо быть програмистом что разобраться что там происходит. А конкретно он меняет лицензию на фришную что б смарт смог работать.+**Правильный вариант только напрячь админа и настроить хостинг что б такого не происходило.**
  
-99% проблем - это запуск скрипта с HTTP_HOST отличным от того для которого выпущена лицензия, о чем скрипт и пишет в scj/logs/error.log  Возникает эта проблема из-за криво настроенного хостинга, что можно видеть по записи в error.log когда на хосте domain.com в error.log записи с http_host = domain2.com+Но есть 2 варианта решить вопрос самому если по какой-то причине админ недоступен
  
-Варианта 2 
-  - напрячь админа 
   - поставить пермишены на файл лицензии (scj2.lic) такие, что б скрипт не мог туда писать   - поставить пермишены на файл лицензии (scj2.lic) такие, что б скрипт не мог туда писать
   - убрать в ioncube_fallback.php строки которые копирую фришную лицензию, а именно   - убрать в ioncube_fallback.php строки которые копирую фришную лицензию, а именно
Line 95: Line 96:
  
  
-Варианты 2 и 3 решат вопрос сразу, но опасны тем что когда закончится лицензия - скрипт не сможет ее обновить и у вас ляжет домен те IonCube, который, напоминаю, запускается ДО скрипта, начнет писать что лицензия не валидна, а сам смарт не сможет ее поменять. В этом случае вам надо будет самостоятельно следить за лицензией.+Варианты 2 и 3 решат вопрос сразу, но опасны тем что когда закончится лицензия - скрипт не сможет ее обновить и у вас ляжет домен тк IonCube, который, напоминаю, запускается ДО скрипта, начнет писать что лицензия не валидна, а сам смарт не сможет ее поменять. В этом случае вам надо будет самостоятельно следить за лицензией.
  
ru/subscription.1599643136.txt.gz · Last modified: by admin