User Tools

Site Tools


Writing /home/user/smartcj.com/wiki/data/cache/1/17ccdda5d10f2c9e1684648967832232.i failed
Unable to save cache file. Hint: disk full; file permissions; safe_mode setting.
Writing /home/user/smartcj.com/wiki/data/cache/1/17ccdda5d10f2c9e1684648967832232.metadata failed
ru:subscription

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
ru:subscription [2024/12/16 20:14] – [Subscription turns into free version] adminru:subscription [2026/06/01 07:52] (current) – [Subscription turns into free version] admin
Line 70: Line 70:
 99% случаев - криво настроен хостинг. 99% случаев - криво настроен хостинг.
  
-Лицензиями занимается IonCube (мод для пхп), те скрипт запускается так: сначала запускается ioncube, проверяет лицензию, если все ок - запускает сам скрипт.+Лицензиями занимается IonCube (мод для пхп), те скрипт запускается так: сначала запускается ioncube, проверяет лицензию, если все ок - запускает сам скрипт. Те лицензиями управляет НЕ SmartCJ.
  
 Если по какой-то причине лицензия не прошла и скрипт не будет запущен, IonCube  запускает файл scj/ioncube_fallback.php , исходник лежит у вас на хосте, не надо быть програмистом что разобраться что там происходит. А конкретно он меняет лицензию на фришную что б смарт смог работать. Если по какой-то причине лицензия не прошла и скрипт не будет запущен, IonCube  запускает файл scj/ioncube_fallback.php , исходник лежит у вас на хосте, не надо быть програмистом что разобраться что там происходит. А конкретно он меняет лицензию на фришную что б смарт смог работать.
  
-99% проблем - это запуск скрипта с HTTP_HOST отличным от того для которого выпущена лицензия, о чем скрипт и пишет в scj/logs/error.log  Возникает эта проблема из-за криво настроенного хостинга, что можно видеть по записи в error.log когда на хосте domain.com в error.log записи с http_host = domain2.com  (либо вообще нет HTTP_HOST, либо например  [HTTP_HOST] => localhost)+99% проблем - это запуск скрипта с HTTP_HOST отличным от того для которого выпущена лицензия, о чем скрипт и пишет в scj/logs/error.log  Возникает эта проблема из-за криво настроенного хостинга, что можно видеть по записи в error.log когда на хосте с domain.com в error.log записи с http_host = domain2.com  (либо вообще нет HTTP_HOST, либо например  [HTTP_HOST] => localhost)
  
 **Правильный вариант только 1 - напрячь админа и настроить хостинг что б такого не происходило.** **Правильный вариант только 1 - напрячь админа и настроить хостинг что б такого не происходило.**
ru/subscription.txt · Last modified: by admin