User Tools

Site Tools


Writing /home/user/smartcj.com/wiki/data/cache/5/5e535036771d5bdb55c48e4269aa842d.i failed
Unable to save cache file. Hint: disk full; file permissions; safe_mode setting.
Writing /home/user/smartcj.com/wiki/data/cache/5/5e535036771d5bdb55c48e4269aa842d.metadata failed
ru:new_rotation_sphinx

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

Both sides previous revisionPrevious revision
Next revision
Previous revision
ru:new_rotation_sphinx [2019/10/30 08:58] adminru:new_rotation_sphinx [2025/05/05 16:30] (current) – [Mysql Search] admin
Line 163: Line 163:
  
  
 +При этом так же нельзя забывать про реиндексацию. например, у нас был поиск "вася", дал 10 реузльтатов и лучшая галера там ИД 123. в базе ИД этой записи например 789 (ИД лучшщей галеры и ИД записи результатов поиска - это разные ИД). Сфинкс возвращает только ИД, в данном случае 789. И вот прошло какое-то время, поискали мы вася и оно вернуло уже другой результат, в базу его записало с ИД 888. А в реиндекса в сфинксе не было. И онвернул старый ид 789, которого уже нет. Или например который сейчас выдает какой-то другой результат, но в любом случае не актуальный.
 ===== Sphinx settings ===== ===== Sphinx settings =====
  
Line 210: Line 210:
  
  
 +===== Sphinx Reindex =====
 +
 +Об этом написано выше, но стоит повторить. Сфинкс - это не магия, он ищет по своему индексу. Свой индекс у него получается когда он проводит индксацию вашей базы. Если вы изменили базу (добавили галер, удалили и тп), а реиндексацию сфинкса не запустили - сфинкс про это не узнает.
 +
 +Это значит, что надо периодически проводоить реиндексацию. лучший вариант: смотреть когда у вас минимальная нагрузка и запускать индексацию в это время по крону.
 ===== Mysql Search ===== ===== Mysql Search =====
  
 По дефолту для поиска используется конструкция примерно WHERE description LIKE '%search_term%'. В настройках ротации есть пункт  По дефолту для поиска используется конструкция примерно WHERE description LIKE '%search_term%'. В настройках ротации есть пункт 
  
-Search fields +  Search fields 
-If you don't use Sphinx the script will use Mysql + 
-built-in functionality. It's slower so we limit amount of fields +  If you don't use Sphinx the script will use Mysql 
-Please, read the last WIKI about the last option. +  built-in functionality. It's slower so we limit amount of fields 
 +  Please, read the last WIKI about the last option. 
  
  
ru/new_rotation_sphinx.1572425915.txt.gz · Last modified: by admin