TCMS и СУБД Percona
Posted: Mon Nov 13, 2017 11:50 am
Во время апдейта вновь установленных TCMS всплыл один нюанс:
Mysql error:: 1064 (You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IGNORE TABLE rot_pages ADD UNIQUE (name)' at line 1) (db_link) in query ALTER IGNORE TABLE rot_pages ADD UNIQUE (name) .....
Также при попытке конвертировать некоторые таблицы в InnoDB вылезли ошибки:
Processing table pornliebe_tcms.rot_cell_data
ERROR 1067 (42000) at line 1: Invalid default value for 'date'
Processing table pornliebe_tcms.rot_comments
ERROR 1067 (42000) at line 1: Invalid default value for 'date'
Processing table pornliebe_tcms.rot_galleries
ERROR 1067 (42000) at line 1: Invalid default value for 'activation_date'
Processing table pornliebe_tcms.rot_page_items
ERROR 1067 (42000) at line 1: Invalid default value for 'date'
Processing table pornliebe_tcms.rot_users
ERROR 1067 (42000) at line 1: Invalid default value for 'reg_date'
У админов есть подозрение что причина возникновении данной ошибки - в несовместимости TCMS и СУБД Percona (на этом сервере установлена Percona, на остальных хостах у нас стандартом является MariaDB). Админы просят узнать мнение разработчиков по этому вопросу.
Mysql error:: 1064 (You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near 'IGNORE TABLE rot_pages ADD UNIQUE (name)' at line 1) (db_link) in query ALTER IGNORE TABLE rot_pages ADD UNIQUE (name) .....
Также при попытке конвертировать некоторые таблицы в InnoDB вылезли ошибки:
Processing table pornliebe_tcms.rot_cell_data
ERROR 1067 (42000) at line 1: Invalid default value for 'date'
Processing table pornliebe_tcms.rot_comments
ERROR 1067 (42000) at line 1: Invalid default value for 'date'
Processing table pornliebe_tcms.rot_galleries
ERROR 1067 (42000) at line 1: Invalid default value for 'activation_date'
Processing table pornliebe_tcms.rot_page_items
ERROR 1067 (42000) at line 1: Invalid default value for 'date'
Processing table pornliebe_tcms.rot_users
ERROR 1067 (42000) at line 1: Invalid default value for 'reg_date'
У админов есть подозрение что причина возникновении данной ошибки - в несовместимости TCMS и СУБД Percona (на этом сервере установлена Percona, на остальных хостах у нас стандартом является MariaDB). Админы просят узнать мнение разработчиков по этому вопросу.