Page 1 of 1

PHP 5.3 в режиме FastCGI дает 500ю ошибку в админке

Posted: Tue Jan 15, 2013 2:56 pm
by ink
Доброго времени суток.
Существует такая проблема на нескольких серверах от разных хостеров.
PHP 5.3.15 в режиме FastCGI - такая проблема последних версий скрипта (билды от ноября и позже) - при входе в админку на главную - сервер долго думает и выдает 500-ю ошибку. Если входить сразу в трейд раздел админки - то все оке. Но для этого нужно либо сначала прибить куки, после неудачного входа на главную админки, либо заходить через период времени когда куки сами умрут.

Если переключить php в режим apache_mod то все работает как и положено.

Может кто сталкивался с такой проблемой или может кто-нибудь знает примерную причину такого конфликта, отпишите плиз.
Так-же было-бы интересно узнать, у кого данные версии PHP в режиме FastCGI прекрасно работают.

о софте сервера -

cPanel Version 11.34.1 (build 7)
Apache version 2.2.22
PHP version 5.3.15
MySQL version 5.1.66-cll
Architecture x86_64
Operating system linux
Kernel version 2.6.32-279.2.1.el6.x86_64

Re: PHP 5.3 в режиме FastCGI дает 500ю ошибку в админке

Posted: Tue Jan 15, 2013 3:45 pm
by admin
какой сейчас билд ?

Re: PHP 5.3 в режиме FastCGI дает 500ю ошибку в админке

Posted: Tue Jan 15, 2013 6:01 pm
by ink
вот такие билды стоят на трех проблемных - Build 201212140921, до этого были что-то из Build 20121128xxxx с такими-же проблемами.
на другом проблемном стоит вот этот - Build 201210020923
вот с этими проблемы нет - Build 201205271145 и Build 201205хххх

Re: PHP 5.3 в режиме FastCGI дает 500ю ошибку в админке

Posted: Tue Jan 15, 2013 6:04 pm
by admin
обновиться пробовали ?
в прелоаде может сотни тысяч файлов ?

Re: PHP 5.3 в режиме FastCGI дает 500ю ошибку в админке

Posted: Tue Jan 15, 2013 8:09 pm
by ink
обновиться пробовали. уже обновляли несоклько раз. в прелоаде нет тысяч файлов, там вообще ничего нет. два из этих сайтов используют external_db
проблема проявляеться когда пхп работает в режиме fastcgi, при apache_mod этой проблемы нет.
хостер и два других админа подтвердили что с софтом все впорядке.

Re: PHP 5.3 в режиме FastCGI дает 500ю ошибку в админке

Posted: Tue Jan 15, 2013 8:13 pm
by admin
ok
что в логах апача на эту ошибку ?

PS или оставьте в личку фтп туда где выдает ошибку и точные действаия что надо сделать что б повторить ошибку.

Re: PHP 5.3 в режиме FastCGI дает 500ю ошибку в админке

Posted: Tue Jan 15, 2013 8:43 pm
by ink
отправил инфу в личку.
более подробно описывал проблему в предыдущей моей теме
http://smartcj.com/viewtopic.php?f=7&t=87358&start=10

и похоже у другого человека такая-же проблема. и вот эта цитата с той темы
"Админ вот что еще написал:
The warning messages about 666 and 777 you can ignore them as that's not compatible with our system configuration. With suphp 644 is the same as 666."
подходит и сюда. Здесь тоже админы сказали что 777 права не сработают, т.к. стоит suphp и cpanel. поэтому все, что должно быть с 777 имеет права 755.

Re: PHP 5.3 в режиме FastCGI дает 500ю ошибку в админке

Posted: Tue Jan 15, 2013 8:51 pm
by admin
Это вопрос какой-то хитрой настройки сервака

Демонстрация пробелмы
<?php
ini_set('error_reporting', E_ALL);
ini_set('display_errors','1');
$config["php_path"] = '/usr/bin/php';
cmd_exec($config["php_path"] . ' -v ', $res, $err);

print_r($res);

function cmd_exec($cmd, &$output, &$error) {

$output = array();
$tmpfname = tempnam("../tmp", "exec");

$cmd = escapeshellcmd($cmd);

exec($cmd . ' 2>' . $tmpfname, $output, $error);
if ($error) {
$output[] = file_get_contents($tmpfname);
}
unlink($tmpfname);

}
?>

можно данный файл залить куда угодно на сервак и открыть в браузере.
Как быстро выполняется ?

Re: PHP 5.3 в режиме FastCGI дает 500ю ошибку в админке

Posted: Tue Jan 15, 2013 9:03 pm
by ink
я знаю этот скритп, лемон его уже давал. есть его модификация. которая отображает процесс.
значит на старом серваке, который имеед апаче_мод режим - тот выполняет быстро и выдает корректно версию пхп.
но на всех новых серваках он генерит сотни экранов кода, который повторяеться через два-три предложения.

вот старый сервер выдает результат (за 1-2 секунды):
Array ( [0] => PHP 5.2.17 (cli) (built: May 3 2011 16:57:28) [1] => Copyright (c) 1997-2010 The PHP Group [2] => Zend Engine v2.2.0, Copyright (c) 1998-2010 Zend Technologies [3] => with the ionCube PHP Loader v4.0.8, Copyright (c) 2002-2011, by ionCube Ltd., and [4] => with Zend Optimizer v3.3.3, Copyright (c) 1998-2007, by Zend Technologies ) 1900410454 : rand 128144

вот новые выдают (за 15-20 секунд, размер нагенеренного кода порядка 10мб, если сохранить его на жестяк):
Array ( [0] => X-Powered-By: PHP/5.3.15 [1] => Content-type: text/html [2] => [3] => Array [4] => ( [5] => [0] => X-Powered-By: PHP/5.3.15 [6] => [1] => Content-type: text/html [7] => [2] => [8] => [3] => Array [9] => [4] => ( [10] => [5] => [0] => X-Powered-By: PHP/5.3.15 [11] => [6] => [1] => Content-type: text/html [12] => [7] => [2] => [13] => [8] => [3] => Array [14] => [9] => [4] => ( [15] => [10] => [5] => [0] => X-Powered-By: PHP/5.3.15 [16] => [11] => [6] => [1] => Content-type: text/html [17] => [12] => [7] => [2] => [18] => [13] => [8] => [3] => Array [19] => [14] => [9] => [4] => ( [20] => [15] => [10] => [5] => [0] => X-Powered-By: PHP/5.3.15 [21] => [16] => [11] => [6] => [1] => Content-type: text/html [22] => [17] => [12] => [7] => [2] => [23] => [18] => [13] => [8] => [3] => Array [24] => [19] => [14] => [9] => [4] => ( [25] => [20] => [15] => [10] => [5] => [0] => X-Powered-By: PHP/5.3.15 [26] => [21] => [16] => [11] => [6] => [1] => Content-type: text/html [27] => [22] => [17] => [12] => [7] => [2] => [28] => [23] => [18] => [13] => [8] => [3] => Array [29] => [24] => [19] => [14] => [9] => [4] => ( [30] => [25] => [20] => [15] => [10] => [5] => [0] => X-Powered-By: PHP/5.3.15 [31] => [26] => [21] => [16] => [11] => [6] => [1] => Content-type: text/html [32] => [27] => [22] => [17] => [12] => [7] => [2] => [33] => [28] => [23] => [18] => [13] => [8] => [3] => Array [34] => [29] => [24] => [19] => [14] => [9] => [4] => ( [35] => [30] => [25] => [20] => [15] => [10] => [5] => [0] => X-Powered-By: PHP/5.3.15 [36]
-бла-бла-бла-
11227672 [3482] => [3477] => [3472] => [3467] => [3462] => ) [3483] => [3478] => [3473] => [3468] => [3463] => 571623339 : rand [3484] => [3479] => [3474] => [3469] => [3464] => 11276168 [3485] => [3480] => [3475] => [3470] => ) [3486] => [3481] => [3476] => [3471] => 161213018 : rand [3487] => [3482] => [3477] => [3472] => 11324800 [3488] => [3483] => [3478] => ) [3489] => [3484] => [3479] => 1430473607 : rand [3490] => [3485] => [3480] => 11373560 [3491] => [3486] => ) [3492] => [3487] => 703507696 : rand [3493] => [3488] => 11422408 [3494] => ) [3495] => 1353920835 : rand [3496] => 11471336 ) 471429342 : rand 11519400

если переключить в апаче_мод - то все этот новый сервак отрабатывает запрос корректно.
но блин, при этом админы утверждают что все прекрасно, все настроено верно, и т.д. партнер и слышать не хочет о переходе в режим apache_mod, потому как там и безопастность хуже и нагрузка будет выше и т.д.
что делать? если я человека из другой ветки такая-же проблема с этим suphpб значит причина может быть в нем?

Re: PHP 5.3 в режиме FastCGI дает 500ю ошибку в админке

Posted: Tue Jan 15, 2013 9:16 pm
by admin
возможно

есть конкретный кусок кода, который никак не связан со скриптов, не использует нкиаких частей скрипт, читый пхп код.

Пусть админ объяснит что у нем неправильно и почему он не выполнается или выполняется но не так..

одинм словом хотелось бы видеть почему он считает что ошибка в этом коде, а не в настройке сервака.