Page 1 of 1

Permission errors

Posted: Fri Jan 04, 2013 4:39 pm
by kefir
I have upgraded to 49 and have now tons of permission errors in the admin. All look similar to these:

Code: Select all

Quick scj folder check returns warnings
Permissions on /home/kefir/virtuals/**********.com/scj/rss.php is 0664, 0644 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin is 0775, 0755 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph is 0775, 0755 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph/jpgraph_bar.php is 0664, 0644 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph/jpgraph_gb2312.php is 0664, 0644 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph/jpgraph_antispam-digits.php is 0664, 0644 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph/jpgraph_error.php is 0664, 0644 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph/jpgraph_antispam.php is 0664, 0644 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph/jpgraph_pie3d.php is 0664, 0644 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph/jpgraph_radar.php is 0664, 0644 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph/jpgraph_canvas.php is 0664, 0644 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph/jpgraph_flags.php is 0664, 0644 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph/jpgraph_plotmark.inc is 0664, 0644 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph/imgdata_diamonds.inc is 0664, 0644 is recommended
Permissions on /home/kefir/virtuals/**********.com/scj/admin/graph/jpgraph_gradient.php is 0664, 0644 is recommended
After fixing some of them I get internal server error... Any idea how to solve it? Or just ignore?

Re: Permission errors

Posted: Fri Jan 04, 2013 5:01 pm
by admin
You have the same error - file are writable by group user, remove this attribute
nternal server error
what do you have in server logs for this ?

Re: Permission errors

Posted: Fri Jan 04, 2013 5:11 pm
by kefir
Is there any way to fix these permissions in bulk? In the previous versions I had no such problem, neither after installation nor upgrade.

Should I ask my server admin to change something? I am about to install couple of fresh SCJ copies and fixing that manually takes hours.

Fixing now to check the Internal Server Error in logs...

Re: Permission errors

Posted: Fri Jan 04, 2013 5:27 pm
by admin
Is there any way to fix these permissions in bulk? In the previous versions I had no such problem, neither after installation nor upgrade.
ask admin to fix it for you

You didnt have those warning caz previous version didnt have file checker.
Should I ask my server admin to change something? I am about to install couple of fresh SCJ copies and fixing that manually takes hours.

yes, it's 1 commend for admin
Fixing now to check the Internal Server Error in logs...
server logs, not scj logs

Re: Permission errors

Posted: Fri Jan 04, 2013 5:40 pm
by kefir
admin wrote:yes, it's 1 commend for admin
Sorry to be pain in the ass but could you point me to the right direction? Either what command should it be or what should I ask for as a permanent solution? I have ssh access of course.

Re: Permission errors

Posted: Fri Jan 04, 2013 5:47 pm
by admin
chmod -gw

but you'd better ask admin to do it: remove write permission for group

Re: Permission errors

Posted: Fri Jan 04, 2013 6:25 pm
by gumsel
Sometimes in a FTP client you can right click the file and set permissions there.

Re: Permission errors

Posted: Fri Jan 04, 2013 6:36 pm
by admin
gumsel wrote:Sometimes in a FTP client you can right click the file and set permissions there.
Yes, but it's faster to do in SSH

Re: Permission errors

Posted: Sat Jan 05, 2013 2:14 am
by kefir
Problem solved. Fresh installations by default have proper permissions, the problem was present only after upgrade from 48 to 49. Maybe there was something wrong with upgrade script...