.Htaccess Error On SCJ

Post Reply
tubeman
Posts: 396
Joined: Sat Mar 02, 2013 11:33 am

.Htaccess Error On SCJ

Post by tubeman » Sat Mar 02, 2013 1:28 pm

Hi,
I installed scj on one of my domains http://www.indianeroticgals.com/ However after
I coped the .htaccess file from the :

/home/httpd/indiamaf/disk2/indianeroticgals.com/html/scj/tube/.htaccess

to the root folder here

/home/httpd/indiamaf/disk2/indianeroticgals.com/html/

The site doesn't load (Gives Centos default page) and admin area gives :
"Forbidden

You don't have permission to access /scj/admin/ on this server."

After I delete the .htaccess file from the root it loads fine but category links don't work.Here is the code in the .htacess file:

____________________________________________________________________________
# This is default example of rewrite rules for SmartCJ Rotation
# You have to move it to the root of your domain and rename to .htaccess

RewriteEngine On
RewriteCond %{QUERY_STRING} ^(.+)$
RewriteRule ^gallery/(.*)/(.*)/index.html$ /scj/cgi/out.php?link=images/%{QUERY_STRING}&url=content&content_id=$2 [L]
RewriteRule ^gallery/(.*)/(.*)/index.html$ /scj/tube/?content_id=$2 [L]
RewriteRule ^gallery/(.*)/(.*)/$ /scj/tube/?content_id=$2 [L]
RewriteRule ^gallery/(.*)/(.*)/([0-9]{1,2}).html$ /scj/tube/?content_id=$2&item_id=$3 [L]

#slug galleries
RewriteCond %{QUERY_STRING} ^(.+)$
RewriteRule ^gallery/([^/]+)/index.html$ /scj/cgi/out.php?link=images/%{QUERY_STRING}&url=content&slug=$1 [L]
RewriteRule ^gallery/([^/]+)/index.html$ /scj/tube/?slug=$1 [L]
RewriteRule ^gallery/([^/]+)/$ /scj/tube/?slug=$1 [L]
RewriteRule ^gallery/([^/]+)/([0-9]{1,2}).html$ /scj/tube/?slug=$1&item_id=$2 [L]

RewriteCond %{QUERY_STRING} ^(.+)$
RewriteRule ^category/([^/]+)/$ /scj/cgi/out.php?link=images/%{QUERY_STRING}&url=content&p=100&skip_to_cookie=true&skip_sell=true&group_name=$1&order=ctr [L]
RewriteRule ^category/([^/]+)/$ /scj/tube/index.php?group_name=$1 [L]
RewriteRule ^category/([^/]+)/([^/]+)/([^/]+)/$ /scj/cgi/out.php?link=images/%{QUERY_STRING}&url=content&p=100&skip_to_cookie=true&skip_sell=true&group_name=$1&order=$2&page=$3 [L]

RewriteRule ^tag/(.*)/$ /scj/tube/index.php?tag=$1
RewriteRule ^search/(.*)/(.*)/(.*)/(.*)/$ /scj/tube/index.php?search_type=$1&search=$2&order=$3&page=$4
RewriteRule ^action/(.*)/(.*)/$ /scj/tube/index.php?action=$1&action_params=$2 [L]
RewriteRule ^action/(.*)$ /scj/tube/index.php?action=$1 [L]

RewriteRule ^go/(.*)/$ /scj/tube/?action=sponsor&sponsor_slug=$1& [L]
RewriteRule ^search_log/(.*)/$ /scj/tube/?search_log=all&page=$1& [L]


RewriteRule ^sponsor/(.*)/$ /scj/tube/?sponsor_slug=$1&force_template=sponsor_page [L]
RewriteRule ^sponsor_galleries/(.*)/(.*)/$ /scj/tube/?sponsor_slug=$1&page=$2&force_template=sponsor_list [L]

RewriteRule ^models/$ /scj/tube/?force_template=model_list [L]
RewriteRule ^models/(.*)/$ /scj/tube/?force_template=model_list&model_first_letter=$1 [L]
RewriteRule ^model/(.*)/(.*)/(.*)/$ /scj/tube/?model_slug=$1&force_template=model_galleries&order=$2&page=$3 [L]
RewriteRule ^model/(.*)/$ /scj/tube/?model_slug=$1&force_template=model_galleries [L]

RewriteRule ^report/(.*)/$ /scj/tube/?content_id=$1&force_template=content_report [L]

_____________________________________________________________________________________

Am I doing anything wrong? Any help would be appreciated.Thanks.

admin
Site Admin
Posts: 26945
Joined: Wed Sep 10, 2008 11:43 am

Re: .Htaccess Error On SCJ

Post by admin » Sat Mar 02, 2013 3:01 pm

Have you done script update ?

tubeman
Posts: 396
Joined: Sat Mar 02, 2013 11:33 am

Re: .Htaccess Error On SCJ

Post by tubeman » Sat Mar 02, 2013 3:21 pm

Hi,
I copied the rules from the article into the .htaccess file that is present in my root directory.Still getting the same error.Any idea how to proceed? Thanks.

admin
Site Admin
Posts: 26945
Joined: Wed Sep 10, 2008 11:43 am

Re: .Htaccess Error On SCJ

Post by admin » Sat Mar 02, 2013 11:01 pm

Hi, what's in webserver error log about this hit ?
Have you done script update ?

tubeman
Posts: 396
Joined: Sat Mar 02, 2013 11:33 am

Re: .Htaccess Error On SCJ

Post by tubeman » Sun Mar 03, 2013 6:53 pm

Hi,
After checking the server logs it seems FollowSymLinks was not added for the domain.Got this fixed and now it works fine.Thanks a lot for your help.Really appreciate it.

admin
Site Admin
Posts: 26945
Joined: Wed Sep 10, 2008 11:43 am

Re: .Htaccess Error On SCJ

Post by admin » Sun Mar 03, 2013 10:46 pm

ok, NP
Have you done script update ?

Post Reply