proxy error

admin
Site Admin
Posts: 24822
Joined: Wed Sep 10, 2008 11:43 am

Re: proxy error

Post by admin » Thu Sep 13, 2018 6:24 am

remove

proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for;
proxy_set_header X-Forwarded-Proto $scheme;
Have you done script update ?

spartan90
Posts: 7
Joined: Wed Sep 12, 2018 12:45 am

Re: proxy error

Post by spartan90 » Thu Sep 13, 2018 6:42 am

I had only proxy_set_header X-Forwarded-For $proxy_add_x_forwarded_for; in etc/nginx/nginx.conf

I have removed but still got the forwarded_for in phpinfo.

You can see here my actual nginx.conf please check if I have to remove anything else: https://pastebin.com/h9uj1GnE

Also I still got the error:

You are behind proxy. This is not an error if you really use proxy. In other case check your SERVER settings. If you use nginx - check WIKI article 'nginx'

Thanks

admin
Site Admin
Posts: 24822
Joined: Wed Sep 10, 2008 11:43 am

Re: proxy error

Post by admin » Thu Sep 13, 2018 6:53 am

Did you reload?
Have you done script update ?

spartan90
Posts: 7
Joined: Wed Sep 12, 2018 12:45 am

Re: proxy error

Post by spartan90 » Thu Sep 13, 2018 7:17 am

Yes, I have restarted also nginx also apache2

admin
Site Admin
Posts: 24822
Joined: Wed Sep 10, 2008 11:43 am

Re: proxy error

Post by admin » Thu Sep 13, 2018 7:50 am

ok, if you can restart it then you somewhat do understand what's going on

Do you know what headers are and what X-Forwarded-For is for ?
Have you done script update ?

Post Reply